Setting up Iannix with Ableton Live ???

Accueil Forums Créer avec IanniX Setting up Iannix with Ableton Live ???

  • Ce sujet contient 38 réponses, 10 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 9 années et 5 mois.
9 sujets de 31 à 39 (sur un total de 39)
  • Auteur
    Messages
  • #2445 Répondre
    Anonyme
    Inactif

    When I set “raw UDP port” to anything other than 2001 it is green, but I get no midi generated.

    #2446 Répondre
    Anonyme
    Inactif

    @Jim wrote:

    When I set “raw UDP port” to anything other than 2001 it is green, but I get no midi generated.

    Following the guide I posted Raw UDP port should by default be set to 57120 and OSC in port should be set to 1222. Just follow the steps and you shouldn’t have to change anything.

    #2448 Répondre
    Anonyme
    Inactif

    A bit of clarification – I’m trying to use osc rather than midi for now. I am using iannixtomidi within max for live to convert osc to midi. I can see that iannixtomidi is set to receive on port 2001 – using ‘udpreceive’. I can see that iannixtomidi can send to iannix (on port 1234), but for some reason getting iannix to send on port 2001 creates a conflict. Must be a windows thing.

    #2447 Répondre
    Anonyme
    Inactif

    Stranger and stranger. I opened the max patch from the iannix demo patches, and it appears to receive osc from iannix. Within live the max patch doesn’t seem to work. Something to do with live options perhaps… ?

    #2449 Répondre
    Anonyme
    Inactif

    I seem to be stumbling on something as well – if anyone can shed some light on this, I’d be hugely grateful! 😀

    I’ve successfully routed the midi tracks in live, with the max 4 live patch loaded, but no signal… I’m wondering if it has to do something with my serial ports, I don’t have much knowledge of OSC or UDP, so I believe this is where my problem lies.

    my ports, as displayed via terminal are:


    Live 4869 NAME 45u IPv4 0x13ee020c 0t0 UDP *:*
    Live 4869 NAME 52u IPv4 0x13ee03c4 0t0 UDP *:*
    Live 4869 NAME 58u IPv4 0x0d9aa20c 0t0 UDP *:2001
    IanniX 4926 NAME 11u IPv4 0x13ee0658 0t0 UDP *:2000
    IanniX 4926 NAME 14u IPv4 0x13ee0130 0t0 UDP *:1234

    attached is a screenshot of my routing attempts in live (8.2.2) & Iannix, but can’t seem to get much headway… I’ve tried changing the OSC in port and Raw UDP port in Iannix several times, along with the “udprecieve” port in max 4 live, but still no avail…

    I’m wondering if it has something to do with my serial port being RED in Iannix, but I can’t seem to figure out how to change or enable it! 🙁

    thanks for your help! this looks so cool to work with, and I want nothing more than to get this working 🙂

    Eoo3

    #2450 Répondre
    Anonyme
    Inactif

    got it working! and all I had to do was change the udprecieve port in M4L to 57120, as in the included Max patch example. For anyone else having a similar problem, double check that the OSC in port in Iannix are 2000 and the Raw UDP port is 1234 (ie, the default settings).

    #2451 Répondre
    Anonyme
    Inactif

    I’m sorry that we change the OSC port from 2001 to 57120 in last version but in Supercollider, the port is 57120 and you can’t change it. So to be compatible, we change all the examples…

    #2452 Répondre
    Anonyme
    Inactif

    Yes! worksw for me with live in windows !!!!!!!!!!!!!!!!!!!!!!

    #2453 Répondre
    Anonyme
    Inactif

    I can’t get iannix to be recgonized in my midi preferences in ableton what do I do?!

9 sujets de 31 à 39 (sur un total de 39)
Répondre à : Répondre #2451 dans Setting up Iannix with Ableton Live ???
Vos informations :





© IanniX Association

Qu'est-ce que IanniX ? | Téléchargement | Showcase | Forum | Recherche | À propos