Communicating with Isadora

Accueil Forums Créer avec IanniX Communicating with Isadora

  • Ce sujet contient 4 réponses, 2 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 9 années et 3 mois.
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2205 Répondre
    Anonyme
    Inactif

    Hi,

    Your software looks great but I just cant seem to get iannix to communicate with isadora (http://www.troikatronix.com/isadora.html) or even osculator, does anyone have any tips and I can get started.

    thanks

    #2655 Répondre
    Anonyme
    Inactif

    Hi!

    IanniX can communication with Isadora! You can use OpenSoundControl (Isadora has a build-in implementation of OSC) or old-school MIDI. You can also use Osculator if you want specific mappings. So I think you have a bug or a configuration problem. Can you explain us your setup and what you’ve tested ?

    #2656 Répondre
    Anonyme
    Inactif

    Thanks for the response, I’m sure I’m just missing something very obvious here.
    Firstly I’m using a Macbook Pro OS 10.6.8, Iannix version0.8.21, isadora version 1.3.0f9.
    Both programmes are running locally on one machine

    I start Iannix and open a pre built example and run it, then open isadora, I click the Communications/Stream Setup dropdown in izzy and click the ‘auto detect input button but nothing appears?? see image[attachment=1:gn34cigh]IannixIntrfce.png[/attachment:gn34cigh] – I have tested TouchOSC with it and it works fine. I have tried typing various TCP numbers in from Iannix -see pic- but nothing, it would appear that Iannix is sending data – see pic[attachment=1:gn34cigh]IannixIntrfce.png[/attachment:gn34cigh]

    I don’t know if this makes any sense to you, communication via networks etc isn’t really my thing however I have hooked up Wiimote and TouchOSC to it in the past with no hitches.

    I can think of some interesting uses for this software collaboration if I ever get it running. Maybe an example iannix/issy setup would be good, if i ever work it out I’ll post one. I have also posted to the Izadora Forum but no response as yet.

    Oh I have tried the MIDI inputs also in izzy and Isadora does see Iannix but the actors do not see any data.

    All the best

    bob

    #2657 Répondre
    Anonyme
    Inactif

    Ok, I will ask Thierry, the project manager, that has knowledge with Isadora. Maybe the default output port (57120) is too high for Isadora…

    #2658 Répondre
    Anonyme
    Inactif

    Hi recieved this message from Michel via the Isadora user forum – it works

    Well you just have to mach the port in Isadora to the IanniX output port, if you look at the sent messages in Iannix you see for example this:

    osc://127.0.0.1:57120/cursor 8 0.420217 0.00640629

    The value after the double dot is the port number. In Isadora you go to the preferences–>Midi/Net and at the bottom of the page you change the port to 57120, after restarting Isadora you go to the menu communications–>stream setup and activate the Auto-Detect Input, then you see the incoming osc messages.

    thanks for your help

    bob

5 sujets de 1 à 5 (sur un total de 5)
Répondre à : Communicating with Isadora
Vos informations:





© IanniX Association

Qu'est-ce que IanniX ? | Téléchargement | Showcase | Forum | Recherche | À propos