Setting up Iannix with Ableton Live ???

Accueil Forums Créer avec IanniX Setting up Iannix with Ableton Live ???

  • Ce sujet contient 38 réponses, 10 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 9 années et 5 mois.
15 sujets de 16 à 30 (sur un total de 39)
  • Auteur
    Messages
  • #2430 Répondre
    Anonyme
    Inactif

    @AvantGuy wrote:

    I enjoyed your video. What screencast software do you use on your Mac? I saw PSP Vintage Warmer sneak in there — I’m also a VW user.

    Cheers,
    –Bob

    Thanks.

    I use screenflow for screencast.

    #2433 Répondre
    IanniX
    Maître des clés

    Did anybody get iannix running with Live without M4L?
    I tried the midi triggers but didn’t get a signal…?
    Not sure how I would use OSC without M4L?

    Thanks for any hints!

    Cheers,

    Tom

    #2434 Répondre
    Anonyme
    Inactif

    The keepers of OSC, OpensoundControl.org, only list this project as an OSC interface to Live (that project appears to be dormant). This gives me the impression the native Live does not implement OSC support. Perhaps M4L is the only alternative at this point. I just visited Ableton’s Live-8 pages, and could find no mention of OSC.

    Cheers,
    –Bob (caveat: I’m not a Live user — perhaps @hendersounds or @mbd73 will confirm)

    @Tom wrote:

    Did anybody get iannix running with Live without M4L?
    I tried the midi triggers but didn’t get a signal…?
    Not sure how I would use OSC without M4L?

    Thanks for any hints!

    Cheers,

    Tom

    #2436 Répondre
    IanniX
    Maître des clés

    @Tom wrote:

    Did anybody get iannix running with Live without M4L?
    I tried the midi triggers but didn’t get a signal…?
    Not sure how I would use OSC without M4L?

    Thanks for any hints!

    Before I got M4L I used the LiveAPI project but I don’t know how compatible it is with the more recent updates. The only other tool I have used is OSCulator http://www.osculator.net/ . Not freeware but can be used without registration with the caveat that every 10 minutes or so it drops the connection and you have to kick it off again. That wasn’t enough of a deterrent for me to use it for a good while as a stop gap for M4L.

    #2437 Répondre
    Anonyme
    Inactif

    And as you can see in our last video (http://vimeo.com/25045003), the next release of IanniX will bring native MIDI support 🙂

    #2438 Répondre
    IanniX
    Maître des clés

    So the instructions in the helpfile are wrong and the midi output simply isn’t there?
    No wonder I got nothing out of it… 😆
    So I guess I wait for the next update…

    Cheers and thanks for the replies!

    Tom

    #2439 Répondre
    Anonyme
    Inactif

    Well MIDI was active, but not really tested with other softwares… And we detected some bugs that we corrected few days ago when making the video. You’ll enjoy these new features in a few days 🙂

    #2432 Répondre
    Anonyme
    Inactif

    Hi,

    This patch seems great and I’ d like to try it (M4L) but the Max Window tells me: Bind to port 2001 unsuccessful, there is probably something already bound to this port.
    I tried to change this one but nothing happens (always the same message in the Max Window)

    Any idea ?

    Thanks
    Nakatano.

    #2431 Répondre
    Anonyme
    Inactif

    Yep, your port seems to be opened by another application (I think it is not Max, because it deals with multiple udpreceive on the same port). Do you still have this problem after restarting?

    #2440 Répondre
    Anonyme
    Inactif

    Hi,

    Yes, I tried to restart many times, but the problem remains the same (Mac OS 10.6.7).
    Strange isn’t it ?
    😕

    #2441 Répondre
    Anonyme
    Inactif

    Here’s a screenshot:

    #2442 Répondre
    Anonyme
    Inactif

    A workaround would be to change the port number in both places: IanniX and Max. But my inclination is to get to the bottom of this.

    So, let’s snoop around and get the rundown on open sockets:

    Open a terminal:

    sudo lsof -i -P

    If you want to see only processes associated with that particular port:

    sudo lsof -i -P | grep "2001"

    If you want to create a file to attach so we can see the output too, you might do this:

    sudo lsof -i -P > MyPorts.txt

    or

    sudo lsof -i -P | grep "2001" > MyPorts.txt

    @nakatano wrote:

    … there is probably something already bound to this port.
    I tried to change this one but nothing happens (always the same message in the Max Window)

    Cheers,
    –Bob

    #2435 Répondre
    Anonyme
    Inactif

    Hey, Nakatano!

    I just took a closer look at your screenshot. It’s Iannix itself that would seem to be competing with Max! You have Iannix also listening on port 2001. I think you want to reverse, in Iannix, those ports 1234 and 2001. Then you should be good to go.

    Cheers,
    –Bob

    @I wrote:

    A workaround would be to change the port number in both places: IanniX and Max. But my inclination is to get to the bottom of this.

    So, let’s snoop around and get the rundown on open sockets:

    Open a terminal:

    sudo lsof -i -P

    If you want to see only processes associated with that particular port:

    sudo lsof -i -P | grep "2001"

    If you want to create a file to attach so we can see the output too, you might do this:

    sudo lsof -i -P > MyPorts.txt

    or

    sudo lsof -i -P | grep "2001" > MyPorts.txt

    @nakatano wrote:

    … there is probably something already bound to this port.
    I tried to change this one but nothing happens (always the same message in the Max Window)

    Cheers,
    –Bob

    #2443 Répondre
    Anonyme
    Inactif

    I posted this in the other thread but think it fits to this one as well. Cheers.

    After a lot of confusion I enlisted the help of a friend Protofuse aka Julian Bayle help get this sorted. There is a couple bugs with the system. For one It won’t work with midi yoke.

    Install loopbe:
    http://nerds.de/en/loopbe1.html

    A more streamlined version of Iannix to midi max device (delete or rename the old one):
    http://www.gamefront.com/files/20675001 … tomidi.rar

    In Ableton:

    The midi channel with the max device should be set MIDI from: all ins + all channels +Monitor Auto + MIDI to whatever vsti + track in

    The midi channel with your vsti should be set MIDI from: Loopbe internal MIDI + All channels + monitor in + audio to master

    The feedback channel if you use one is configured the same.

    Now open IanniX and run the the Simple Midi Example template.

    In the script editor copy and paste this over the script and click save:
    http://pastebin.com/pEta8Dzz

    It should work now.

    #2444 Répondre
    Anonyme
    Inactif

    I would love to get this working for me !

    I’m using max for live on windows. I’ve got iannixtomidi loaded, but when I start iannix “raw UDP port (2001)” is red.

15 sujets de 16 à 30 (sur un total de 39)
Répondre à : Setting up Iannix with Ableton Live ???
Vos informations :





© IanniX Association

Qu'est-ce que IanniX ? | Téléchargement | Showcase | Forum | Recherche | À propos