no sound avec ubuntu studio

Accueil Forums Bugs no sound avec ubuntu studio

Ce sujet a 12 réponses, 2 participants et a été mis à jour par  gregja, il y a 1 an et 3 mois.

13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #5444 Répondre

    gregja

    Bonjour,
    Mon PC tourne sous Ubuntu Studio, j’ai branché Iannix sur différents périphériques Midi (synthé microbrute, piano numérique), et je n’arrive pas à envoyer de signaux Midi vers ces instruments.
    J’utilise une interface USB/Midi qui fonctionne très bien avec d’autres logiciels comme par exemple Rosegarden.
    Toute aide serait bienvenue. Un grand merci par avance.
    A+

    #5445 Répondre

    IanniX
    Admin bbPress

    Bonjour,

    Normalement, ça marche en effet direct, dès que vous lancez un des exemples fournis avec IanniX, du MIDI (CC, note on/off) est censé être envoyé. Vérifiez dans l’onglet CONFIG > MIDI le bus MIDI de sortie. Par défaut — et je crois également sur Ubuntu —, IanniX créé un port MIDI virtuel « From IanniX » afin que les logiciels tiers le voient. Dans ce menu, vous devriez avoir votre MicroBrute et le MIDI out USB. Est-ce le cas ?

    #5453 Répondre

    gregja

    bonjour, merci pour le retour.
    dans l’onglet MIDI j’ai bien l’option « enable Midi » cochée, et je peux choisir entre plusieurs périphériques, dont :
    – microbrute:0
    – microbrute:1
    (tous deux visibles en connexion USB directe, tous deux testés, sans résultat)

    j’ai aussi la possibilité de me connecter avec une interface externe USB/Midi Prodipe, testée avec le Microbrute, mais aussi avec un piano numérique Yamaha, toujours sans résultat. L’interface apparaît dans IanniX sous la dénomination suivante :
    – usb midi interface:0

    Avec la connexion USB directe sur le microbrute, j’arrive à récupérer des signaux Midi provenant du microbrute, dans la log des entrées de IanniX (cf. échantillon suivant) :
    00:17:44:895 : midi://midiin note 1 57 (A3) 0
    00:17:45:095 : midi://midiin cc 1 7 72
    00:17:45:095 : midi://midiin cc 1 7 72

    mais les signaux Midi émis par IanniX ne déclenchent aucun son du côté du Microbrute, alors qu’ils semblent corrects (cf. échantillon ci-dessous) :
    00:18:42:495 : midi://microbrute:0/notef 1 0 (C-1) 30 1 (1 s.)
    00:18:42:495 : midi://microbrute:0/notef 1 0 (C-1) 2 1 (1 s.)
    00:18:42:495 : midi://microbrute:0/notef 1 6 (F#-1) 15 1 (1 s.)
    00:18:42:793 : midi://microbrute:0/notef 1 30 (F#1) 22 1 (1 s.)

    à ce stade, je donne ma langue au chat.
    toute suggestion est bienvenue.
    merci par avance.

    #5456 Répondre

    IanniX
    Admin bbPress

    Oui, ça a l’air de marcher en fait, mais les notes jouées sont hyper graves (DO octave MIDI -1, F# même octave…). Est-ce que vous jouez les exemples ou autre chose ? L’exemple Rosette génère des notes dans la bonne octave par exemple, pourriez-vous l’exécuter ?

    #5460 Répondre

    gregja

    Bonsoir,
    Désolé pour la réponse tardive, je vous confirme que j’ai utilisé exclusivement les exemples fournis avec IanniX. Je me souviens d’avoir testé l’exemple « rosette », sans résultat. Je suis en déplacement pour quelques jours, je pourrai refaire de nouveaux tests en fin de semaine, si vous avez des pistes à me proposer.

    #5461 Répondre

    gregja

    bonjour,
    j’ai refait quelques tests aujourd’hui avec IanniX installé sur un Mac et IanniX installé sur Ubuntu Studio.
    à configuration similaire, et en utilisant la même interface USB/MIDI externe :
    – à partir du Mac : j’ai réussi sans problème à envoyer des signaux MIDI sur un synthé Microbrute
    – à partir d’Ubuntu : je ne suis pas parvenu à envoyer de signaux MIDI sur le même synthé
    il y a peut être bien un souci avec la version de IanniX pour Linux, en tout cas dans ma config tournant sur Ubuntu Studio. Je n’ai pas eu l’occasion de faire des tests sur d’autres distrib Linux.

    #5462 Répondre

    IanniX
    Admin bbPress

    Ouais en effet, et comme nous ne sommes pas très doués en Linux, si quelqu’un peut nous aider sur le code (facile à compiler avec Qt), ça serait chouette !

    #5463 Répondre

    Alberto Zin

    Hello, sorry for the English speaking in this thread.
    I have the same issue as greja: I’m in linux Mint 18.3 (based on Ubuntu 16.04, the latest long term support).
    As greja I’m able to send note in messages to Iannix with format:

    00:03:56:861 : midi://midiin note 1 62 (D4) 63
    00:03:57:062 : midi://midiin note 1 62 (D4) 0
    00:03:57:262 : midi://midiin note 1 62 (D4) 67
    00:03:57:412 : midi://midiin note 1 62 (D4) 0

    but whatever attempt I do on Midi Ports and even if the messages seems fine no Midi output messages are seen (I use a Midi monitor utility). Please let me know how can I help the debug of this issue.

    Best regards,

    Alberto

    #5464 Répondre

    Alberto Zin

    Hello again, I was able to compile Iannix and start it in debug mode in Qt creator.
    I set breakpoints where midi message should be produced,
    but again no signs of life on alsa midi connections. Anything I should check while in debug?

    Alberto

    #5466 Répondre

    IanniX
    Admin bbPress

    Hi Alberto and gregja,

    The bug is now fixed I think ; it was due to the character ‘:’ in Linux MIDI port names. I’ve committed the patch and I’ll publish the release+binary next week if I can.
    Can you confirm me it’s ok?

    #5467 Répondre

    Alberto Zin

    Hello, thanks for the feedback.

    I grabbed the last github source, including your last commit (I checked that is present)
    but for me it is still « no-go »: I’ve no output from Midi (whatever it is: « from_Iannix » or « Midi Through »)
    Did you try on a Linux machine (or virtual one)?
    Let me know if I can help.

    BTW: in order to build from source I’ve to do 2 small modifications to the code:

    1. the first one is related to a devicePixelRatioFScale(), which is undefined in my environment (I understand it is part of Qt 5.6 while I’ve 5.5). I replaced it with 0x10000 where it is present.
    2. I had to comment the two lines:
    setWindowFlag(Qt::WindowMaximizeButtonHint, false);
    setWindowFlag(Qt::WindowMinimizeButtonHint, false);

    in uihelp.cpp (error message tells me that setWindowFlag is undefined in scope). I don’t think that this is a big issue anyway

    Thanks again,

    Alberto

    #5468 Répondre

    IanniX
    Admin bbPress

    Hi Alberto,

    Yes I tested on Ubuntu with Parallel Desktop for Mac + kMIDIMon (on the Ubuntu VM) for MIDI debug, and I saw MIDI events from IanniX in the monitor… I think I have to test directly with Ubuntu Studio, but I will need more time to do that!

    Thanks for the feedback on modifications to build with Linux, I’ll add some directive in order to compile properly with Qt5.5

    #5469 Répondre

    gregja

    Thank’s a lot to Alberto and to the IanniX team. If you find a solution for that problem, I will be happy to do some tests.
    Best regards

13 sujets de 1 à 13 (sur un total de 13)
Répondre à : no sound avec ubuntu studio
Vos informations:





© IanniX Association

Qu'est-ce que IanniX ? | Téléchargement | Showcase | Forum | Recherche | À propos