Mac OS X compatibility

Home Forums Bugs Mac OS X compatibility

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #2129 Reply

    Hi, just thought I’d report in. I’m finding that every time I try to open IanniX, I get the “The application IanniX quit unexpectedly” dialog. When I select to report the problem, this is what I get (don’t know if this is helpful to you):

    Date/Time:      2011-05-22 23:20:57.306 +0100
    OS Version: 10.4.11 (Build 8S2167)
    Report Version: 4

    Command: IanniX
    Path: /Applications/IanniX/
    Parent: WindowServer [59]

    Version: ??? (???)

    PID: 368
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

    Thread 0 Crashed:
    0 <<00000000>> 0x00000000 0 + 0
    1 QtGui 0x0105af96 QMacStyle::polish(QPalette&) + 70
    2 QtGui 0x0108f044 QApplicationPrivate::setPalette_helper(QPalette const&, char const*, bool) + 68
    3 QtGui 0x0108f580 QApplication::setPalette(QPalette const&, char const*) + 32
    4 QtGui 0x0108f616 QApplicationPrivate::setSystemPalette(QPalette const&) + 134
    5 QtGui 0x01091693 QApplication::style() + 387
    6 QtGui 0x01021f3f QApplicationPrivate::initializeWidgetPaletteHash() + 4047
    7 QtGui 0x010236a2 QApplicationPrivate::initializeWidgetPaletteHash() + 10034
    8 QtGui 0x010981e3 QApplicationPrivate::construct() + 195
    9 QtGui 0x01098696 QApplication::QApplication[not-in-charge](int&, char**, int) + 102
    10 IanniX 0x000742b3 IanniXApp::IanniXApp[not-in-charge](int&, char**) + 51
    11 IanniX 0x00074b5e main + 46
    12 IanniX 0x00006c4d _start + 208
    13 IanniX 0x00006b7c start + 40

    Thread 0 crashed with X86 Thread State (32-bit):
    eax: 0x02917380 ebx: 0x0110a584 ecx: 0xa0813d04 edx: 0xffffffff
    edi: 0x02917e30 esi: 0xbffff6bc ebp: 0xbffff648 esp: 0xbffff5ec
    ss: 0x0000001f efl: 0x00010286 eip: 0x00000000 cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037

    Binary Images Description:
    0x1000 - 0x140fff IanniX /Applications/IanniX/
    0x305000 - 0x54cfff QtScript /Applications/IanniX/
    0x583000 - 0x63ffff QtOpenGL /Applications/IanniX/
    0x65f000 - 0x763fff QtNetwork /Applications/IanniX/
    0x1008000 - 0x1973fff QtGui /Applications/IanniX/
    0x1ab8000 - 0x1d17fff QtCore /Applications/IanniX/
    0x1d63000 - 0x1e41fff libxml2.2.dylib /usr/lib/libxml2.2.dylib
    0x8fe00000 - 0x8fe4afff dyld 46.16 /usr/lib/dyld
    0x90000000 - 0x90171fff libSystem.B.dylib /usr/lib/libSystem.B.dylib
    0x901c1000 - 0x901c3fff libmathCommon.A.dylib /usr/lib/system/libmathCommon.A.dylib
    0x901c5000 - 0x90202fff 1.1.3 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreText.framework/Versions/A/CoreText
    0x90229000 - 0x902fffff ATS /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/ATS
    0x9031f000 - 0x90774fff 1.258.85 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
    0x9080b000 - 0x908d3fff 6.4.11 (368.35) /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x90911000 - 0x90911fff 10.4 (???) /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
    0x90913000 - 0x90a07fff libicucore.A.dylib /usr/lib/libicucore.A.dylib
    0x90a57000 - 0x90ad6fff libobjc.A.dylib /usr/lib/libobjc.A.dylib
    0x90aff000 - 0x90b63fff libstdc++.6.dylib /usr/lib/libstdc++.6.dylib
    0x90bd2000 - 0x90bd9fff libgcc_s.1.dylib /usr/lib/libgcc_s.1.dylib
    0x90bde000 - 0x90c51fff 1.4.8 (???) /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
    0x90c66000 - 0x90c78fff libauto.dylib /usr/lib/libauto.dylib
    0x90c7e000 - 0x90f24fff 682.31 (682.32) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
    0x90f67000 - 0x90fcffff 4.1 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
    0x91008000 - 0x91047fff 129.24 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
    0x9105a000 - 0x9106afff 1.1.3 (1.1.0) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/WebServicesCore.framework/Versions/A/WebServicesCore
    0x91075000 - 0x910f4fff 1.0.8 /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
    0x9112e000 - 0x9114cfff 10.4.4 (121.36) /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
    0x91158000 - 0x91166fff libz.1.dylib /usr/lib/libz.1.dylib
    0x91169000 - 0x91308fff 4.5.2 (29774) /System/Library/Frameworks/Security.framework/Versions/A/Security
    0x91406000 - 0x9140efff 2.1.2 /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
    0x91415000 - 0x9141cfff libbsm.dylib /usr/lib/libbsm.dylib
    0x91420000 - 0x91446fff 1.8.6 /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
    0x91458000 - 0x914cefff 3.0.5 /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
    0x9151f000 - 0x9151ffff 10.4 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
    0x91521000 - 0x9154dfff 316.3 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
    0x91560000 - 0x91634fff 4.4.13 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ColorSync.framework/Versions/A/ColorSync
    0x9166f000 - 0x916e2fff 4.6 (177.13) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/PrintCore.framework/Versions/A/PrintCore
    0x91710000 - 0x917b9fff 3.10.28 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/QD.framework/Versions/A/QD
    0x917df000 - 0x9182afff 1.5.2 (???) /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/HIServices.framework/Versions/A/HIServices
    0x91849000 - 0x9185ffff 1.6.3 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LangAnalysis.framework/Versions/A/LangAnalysis
    0x9186b000 - 0x91886fff 1.5 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/FindByContent.framework/Versions/A/FindByContent
    0x91891000 - 0x918cefff 183.1 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
    0x918e2000 - 0x918eefff 3.5 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesis
    0x918f5000 - 0x91935fff 1.5.9 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
    0x91948000 - 0x919fafff libcrypto.0.9.7.dylib /usr/lib/libcrypto.0.9.7.dylib
    0x91a40000 - 0x91a56fff libcups.2.dylib /usr/lib/libcups.2.dylib
    0x91a5b000 - 0x91a79fff libJPEG.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJPEG.dylib
    0x91a7e000 - 0x91addfff libJP2.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libJP2.dylib
    0x91aef000 - 0x91af3fff libGIF.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libGIF.dylib
    0x91af5000 - 0x91b7dfff libRaw.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRaw.dylib
    0x91b81000 - 0x91b9cfff libPng.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
    0x91ba1000 - 0x91ba3fff libRadiance.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libRadiance.dylib
    0x91ca0000 - 0x91cdffff libTIFF.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
    0x91ce5000 - 0x91ce5fff 1.3.1 (Accelerate 1.3.1) /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
    0x91ce7000 - 0x91d75fff 2.5 /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
    0x91d7c000 - 0x91d7cfff 3.3.1 (vecLib 3.3.1) /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
    0x91d7e000 - 0x91dd7fff libvMisc.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib
    0x91de0000 - 0x91e04fff libvDSP.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib
    0x91e0c000 - 0x92215fff libBLAS.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
    0x9224f000 - 0x92603fff libLAPACK.dylib /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
    0x92630000 - 0x9271dfff libiconv.2.dylib /usr/lib/libiconv.2.dylib
    0x9271f000 - 0x9279dfff 1.3.7 /System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/DesktopServicesPriv
    0x927de000 - 0x92a16fff 6.4.12 (567.42) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x92b36000 - 0x92b4dfff libGL.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
    0x92b58000 - 0x92bb0fff libGLU.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLU.dylib
    0x92bc4000 - 0x92bc4fff 10.4 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x92bc6000 - 0x92bd6fff 3.0.4 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/ImageCapture
    0x92be5000 - 0x92bedfff 3.6 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SpeechRecognition.framework/Versions/A/SpeechRecognition
    0x92bf3000 - 0x92bf9fff 2.0.1 (24742) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.framework/Versions/A/SecurityHI
    0x92bff000 - 0x92c90fff 101.2.1 (71) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework/Versions/A/Ink
    0x92ca4000 - 0x92ca8fff 1.0.3 (32.1) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Help.framework/Versions/A/Help
    0x92cab000 - 0x92cc9fff 1.2.7 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting.framework/Versions/A/OpenScripting
    0x92cdb000 - 0x92ce1fff 5.2 (192.4) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framework/Versions/A/Print
    0x92ce7000 - 0x92d4afff 66.1 (1.1.3) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HTMLRendering.framework/Versions/A/HTMLRendering
    0x92d71000 - 0x92db2fff 3.4.4 (3.4.3) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/NavigationServices.framework/Versions/A/NavigationServices
    0x92dd9000 - 0x92de7fff 3.9.1 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CarbonSound.framework/Versions/A/CarbonSound
    0x92dee000 - 0x92df3fff 1.2.3 (73) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels.framework/Versions/A/CommonPanels
    0x92df8000 - 0x930edfff 1.4.10 (???) /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
    0x931f3000 - 0x931fefff 1.4.16 /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
    0x93290000 - 0x93946fff 6.4.10 (824.48) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
    0x93cc7000 - 0x93d42fff 91 (92.1) /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
    0x93d7b000 - 0x93e34fff 1.4.7 /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
    0x93e77000 - 0x93e77fff 1.4.2 /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit
    0x93e79000 - 0x9403afff 1.4.12 /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
    0x94080000 - 0x940c1fff libsqlite3.0.dylib /usr/lib/libsqlite3.0.dylib
    0x940c9000 - 0x94103fff libGLImage.dylib /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLImage.dylib
    0x94108000 - 0x9411efff 1.4.2 /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
    0x942c9000 - 0x942d4fff libCSync.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCSync.A.dylib
    0x94320000 - 0x9433afff libRIP.A.dylib /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A.dylib
    0x961a6000 - 0x961dcfff 1.5.1 (41) /System/Library/Frameworks/CoreMIDI.framework/Versions/A/CoreMIDI
    0x96c8b000 - 0x96c90fff 2.5.9 (AGL-2.5.9) /System/Library/Frameworks/AGL.framework/Versions/A/AGL

    Model: MacBookPro2,1, BootROM MBP21.00A5.B08, 2 processors, Intel Core 2 Duo, 2.33 GHz, 2 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 1 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: AirPort Extreme, 1.4.4
    Bluetooth: Version 1.9.5f4, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS541616J9SA00, 149.05 GB
    Parallel ATA Device: MATSHITADVD-R UJ-85J
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA

    I’m running an intel mac on Tiger 10.4.11.

    #2316 Reply

    Well, I’m not sure that IanniX can run on Tiger. I’ll make some tests and give you an answer in a few days.

    #2317 Reply

    Ah, ok. That might be why then 😳

    I knew I’d have to upgrade at some point (when Apple started classing my computer as “legacy”). May have to just bite the bullet.

    #2318 Reply

    Well, IanniX is not compatible with Tiger… You need Leopard or Snow Leopard. Sorry 🙁

    #2319 Reply

    Probably best to document this on the downloads page so people with os x4.11 (like me) don’t bother downloading something that doesn’t work…

    #2320 Reply

    I added a “10.5+” on download pages.

    #2321 Reply

    @Guillaume wrote:

    I added a “10.5+” on download pages.

    thanks, looks like I’ll have to upgrade… I can keep my download until then…

    #2323 Reply

    Hey Team. Having unexpected quits on launch on 10.6.6 as well. Looks like a Qt problem? Not sure whats going on here – have un- and re- installed Qt, Dev tools, everything. No dice. Here’s the crashlog:

    Process: IanniX [33417]
    Path: /Applications/IanniX/
    Identifier: IanniX
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [167]

    Date/Time: 2011-07-02 16:04:02.093 -0400
    OS Version: Mac OS X 10.6.6 (10J567)
    Report Version: 6


    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
    Crashed Thread: 0 Dispatch queue:

    Thread 0 Crashed: Dispatch queue:
    0 ??? 000000000000000000 0 + 0
    1 QtCore 0x00000001013cf566 QFontLaoCodec::convertFromUnicode(QChar const*, int, QTextCodec::ConverterState*) const + 3702
    2 QtCore 0x00000001012d1550 QTextCodec::fromUnicode(QString const&) const + 32
    3 QtCore 0x00000001012aa923 QString::toLocal8Bit() const + 51
    4 QtCore 0x0000000101378247 QFSFileEngine::open(QFlags) + 1207
    5 QtCore 0x000000010137fae9 QFSFileEngine::fileName(QAbstractFileEngine::FileName) const + 1833
    6 QtCore 0x00000001012b2533 QDir::canonicalPath() const + 51
    7 QtCore 0x00000001012c9d74 QCoreApplication::libraryPaths() + 372
    8 QtCore 0x00000001013a4aec QCoreApplication::init() + 204
    9 QtCore 0x00000001013a4c01 QCoreApplication::QCoreApplication(QCoreApplicationPrivate&) + 49
    10 QtGui 0x00000001006147a3 QApplication::QApplication(int&, char**, int) + 83
    11 IanniX 0x00000001000680a0 IanniXApp::IanniXApp(int&, char**) + 48
    12 IanniX 0x00000001000689bc main + 28
    13 IanniX 0x0000000100005524 start + 52

    Thread 1: Dispatch queue:
    0 libSystem.B.dylib 0x00007fff806d216a kevent + 10
    1 libSystem.B.dylib 0x00007fff806d403d _dispatch_mgr_invoke + 154
    2 libSystem.B.dylib 0x00007fff806d3d14 _dispatch_queue_invoke + 185
    3 libSystem.B.dylib 0x00007fff806d383e _dispatch_worker_thread2 + 252
    4 libSystem.B.dylib 0x00007fff806d3168 _pthread_wqthread + 353
    5 libSystem.B.dylib 0x00007fff806d3005 start_wqthread + 13

    Thread 2:
    0 libSystem.B.dylib 0x00007fff806d2f8a __workq_kernreturn + 10
    1 libSystem.B.dylib 0x00007fff806d339c _pthread_wqthread + 917
    2 libSystem.B.dylib 0x00007fff806d3005 start_wqthread + 13

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x0000000000000000 rbx: 0x000000010162de80 rcx: 0x0000000101630638 rdx: 0x00000000ffffffff
    rdi: 0x0000000101406090 rsi: 0x00000001014022ec rbp: 0x00007fff5fbfeea0 rsp: 0x00007fff5fbfee28
    r8: 0x00000001015064e8 r9: 0x00000001016fc0a4 r10: 0x0000000000000005 r11: 0x0000000101630630
    r12: 0x00000001014022ec r13: 0x0000000000000000 r14: 0x00000001016155d0 r15: 0x0000000000000030
    rip: 0x0000000000000000 rfl: 0x0000000000010246 cr2: 0x0000000000000000

    Iannix worked great before I upgraded to Snow Leopard and then blammo… unexpected quits. I thought I might try compiling from the source, but the Qt opensource SDK installer ALSO quits on launch. 😡

    Any ideas?

    #2322 Reply

    @mrgosh wrote:

    Hey Team. Having unexpected quits on launch on 10.6.6 as well. Looks like a Qt problem? Not sure whats going on here – have un- and re- installed Qt, Dev tools, everything. No dice. Here’s the crashlog:
    Any ideas?

    Just to double-check: Is this your own build, or did you install from iannix_mac__0_8_21.dmg ?


    #2324 Reply

    I’m trying to run from an install of the latest release, yeah. Not building from source.

    #2325 Reply

    In my experience, that 0.8.21 Iannix build runs perfectly on OSX 10.6.7, so there might be something anomalous in your installation.

    Did Iannix crash on its very first invocation following your upgrade from 10.5, or were you able to open a score or do some edits before it began crashing on launch? I’m wondering if it is attempting to load a file that is corrupted (sometimes apps in early beta don’t have all the input validation in place, and bad data might cause an out-of-bounds access). To eliminate the possibility of a bad startup file, you might try temporarily relocating your data out of the “Project” subfolder so Iannix will not find anything to open upon launching.

    When you upgraded to 10.6, did you do a clean install or an upgrade install? I don’t have any particular issue in mind, but if you did an upgrade, I wonder if some kind of corruption of your app occurred. If you haven’t already done so, it might be worth your time to reinstall Iannix.

    Yes, from your stack trace, it does look like it was in a QT call before vectoring through address zero, but 90% of the time an app built on QT will be inside a library call. The invalid access comes out of the Unicode conversion call, and that might be while parsing the name of the default score file. It is unlikely to be a “QT problem”, per sé, because all of the QT runtime support required by Iannix is inside of — your QT dev tool installation should have no bearing on this.

    @mrgosh wrote:

    I’m trying to run from an install of the latest release, yeah. Not building from source.


    #2326 Reply

    Hmmm, Ok. So the plot thickens!

    After double and triple checking that all my other software would still work, I updated to 10.6.7 and I’m still getting crashes. My update from 10.5 to 10.6 was a clean install; all subsequent updates have been combo updates (the ones recommended by Digi since I use ProTools all day for work).

    The crashing was instantaneous on my upgrade to 10.6. There was no period where I would work and Iannix would crash. And actually I remember teaching a MaxMSP class in which my machine running 10.5 ran Iannix fine and none of the student computers running 10.6 could run it. Didn’t check the crashlogs! Wish I had now.

    Anyway, after updating 10.6.7 I also tried running every Mac release of Iannix. No dice. It’s a crash party, and everyone is invited. Removing default project files had no effect.

    Now get THIS: Nothing Qt works anywhere on my system. The Online Qt SDK installer quits on launch (downloaded this in an attempt to build Iannix from source). All the Qt Tools (creator, assistant, etc) all quit on launch (and they all cite converttoUnicode in their crashlogs). This has not always been the case, but I can’t say when exactly this began happening since I do not regularly use Qt anything. Anyway… THIS problem seems to be all over the net (, Seems more and more like these might be related?

    This might no longer be a “Mac OS X compatibility” issue, but a my-machine-specifically issue. I’m gonna set about deactivating large groups of fonts just for fun? See if I can’t track something down, hopefully save someone this headache in the future.

    #2327 Reply

    …related? I think you might be teasing us with an understatement :–) It sure does look related. A comparison of your crash dump with that QT bug report crash dump is more like twins than kissing cousins. Both crashes occur very early in the app startup sequence. I mean, when you can see the entry to main() less than a dozen stack frames before the crash, you *know* the app is still cranking its engine when it dies. Plus, they both croak from that Unicode call (well, you got one more stack frame before death than did this other event, but that might just be a difference in QT versions and some kind of function re-factoring QT might have done).

    It’s looking to me like this issue results from a combination of a particular hardware configuration and OSX 10.6, based on the problem-free experience I’ve had with Snow Leopard. Just what is your hardware? Mine is a first generation Macbook with RAM maxed out.

    Have you applied all CMOS patches to your hardware? You might want to ensure you’re totally up to date with system patches.


    #2328 Reply

    Understatement be my curse!

    I’m on a 2.8Ghz MBPro5,1 4G ram (max).

    Found some troublesome fonts and killed them but that didn’t make any difference (it was a longshot anyway, I know). My SMC and bootrom are both up-to-date. The only thing I’m not up to date on is OS because digi hasn’t qualified 10.6.8 yet (of course).

    This is one hell of a mystery – on both the Iannix and Qt-in-general fronts.

    EDIT: I wonder if its possible that this is a 32-bit v 64-bit problem. That might set off all these flags… Bob, is your machine Core2Duo or no? Mine has 1x 64-bit core.

    #2329 Reply

    @Guillaume wrote:

    I added a “10.5+” on download pages.

    but 10.5 is tiger. its crashing for me also (10.5.8) do you perhaps mean 10.6+ ?

    Thread 0 Crashed:
    0 libSystem.B.dylib 0x00007fff81c1f730 strlen + 16
    1 ...ple.ApplicationServices.ATS 0x00007fff811d6536 _eATSSendFontQuery + 430
    2 ...ple.ApplicationServices.ATS 0x00007fff811bd374 _eATSFontFindFromName + 472
    3 ...ple.ApplicationServices.ATS 0x00007fff811bd181 ATSFontFindFromName + 67
    4 QtGui 0x00000001007d851c QFontDatabase::load(QFontPrivate const*, int) + 2460
Viewing 15 posts - 1 through 15 (of 17 total)
Reply To: Mac OS X compatibility
Your information:

© IanniX Association

What is IanniX? | Download | Showcase | Forums | Research | About